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CHAPTER

ONE

INSTALLATION

(a) Windows (b) macOS

(c) Linux (Ubuntu) (d) Linux (RaspberryPi)

Fig. 1.1: TII Spectrometry on different platforms.

TII Spectrometry is a cross-platformapplication to control integrated visible or infrared light spec-
trometers and analyze the acquired spectra. Installation of the software differs by platform:

• on Windows, simply copy the TII Spectrometry folder to any desired location and
double-click on TII-Spectrometry.exe

• on macOS, drag the TII-Spectrometry bundle to the Applications folder. The app can
be opened by double-clicking TII-Spectrometry

• on Linux navigate to the folder containing the TII-Spectrometry.deb file and execute
sudo dpkg -i TII-Spectrometry.deb. This will add TII Spectrometry to the desktop
menu.

INFO-CIRCLE Note
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The TII-Spectrometry.deb contains *.rules files to grant USB access to TII Spec-
trometry, which will be installed to /etc/udev/rules.d/ using the above command. A
reboot or log-in / log-out cycle may be required to gain access to USB devices after the
first installation.

1.1 Supported Devices & Environments

TII Spectrometry supports theWindows,macOS (Apple Silicon) and Linux operating environments.
On Linux, both x64 (i.e. desktop computers) and arm64 (e.g. RaspberryPi single-board computers)
are supported. Most spectrometers are supported on all platforms, see Table 1.1 for exceptions.
Simultaneous control of multiple supported spectrometers (page 17) is supported.

Table 1.1: Supported Devices & Environments

Windows macOS Linux (x64) Linux (arm64)

Avenir2 XXX XXX XXX XXX
StellarNet3 XXX XXX XXX XXX
NLIR Midwave4 XXX XXX XXX XXX
ARCoptix FTIR5 XXX XXX6 XXX

2 https://www.avenirphotonics.com/
3 https://www.stellarnet.us/
4 https://nlir.com/
5 https://arcoptix.com/
6 Requires Ubuntu 22 (Jammy Jellyfish)
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CHAPTER

TWO

RECORDING SPECTRA

This section describes the operation of single or multiple connected spectrometers controlled by
TII Spectrometry. Section 2.1 describes the features common to all spectrometers, Section 2.2
has additional information specific to particular spectrometers, and Section 2.3 describes how
to control multiple spectrometers simultaneously. Section 2.4 contains information on how to
acquire spectral time-lapse recordings.

2.1 General Use

This section describes how to acquire single spectra using TII Spectrometry.

Fig. 2.1: The TII Spectrometry user interface.

The main window of TII Spectrometry is divided into three sections:

1. The top bar (page 4) (red box in Figure 2.1) configures spectral acquisition an display

2. the sidebar (page 6) (green box in Figure 2.1) contains saved spectra and allows selecting
background and reference spectra (page 7)

3. The spectrum view (page 7) (blue box in Figure 2.1) contains one or more spectra.

3
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2.1.1 Connection

To connect to a spectrometer, use any of the following methods:

• select File ‣ Connect ‣ Connect. This will connect to the first detected spectrometer.

• select File ‣ Connect ‣ Device Manager to open the Device Manager and select the desired spec-
trometer(s) from the list. For details see the section Using Multiple Spectrometers (page 17).

• open a device configuration file (page 5) using File ‣ Connect ‣ Load Configuration. This will
connect to the spectrometers in the configuration file if they are connected to the computer.

If the connection was successful, the connected spectrometer(s) will be displayed in the title bar
of the TII Spectrometry window and the Single and Acquire buttons become active (Figure 2.1).

2.1.2 Device Configuration

The top bar of the TII Spectrometry window (red box in Figure 2.1) allows the configuration of
the most relevant experimental parameters:

Spectral Acquisition

Single
Acquires a single spectrum using the current configuration

Acquire
Starts the spectrometer and continuously acquires spectra. Clicking the Stop button stops
continuous acquisition.

Avg. #
Selects the number of spectra to average. Use this to improve the signal-to-noise ratio

Exposure Time
The exposure time of the detector in milli-seconds.

SHARE See also

Averaging and exposure time can be set individually for each connected spectrometer, see
section Using Multiple Spectrometers (page 17) for details.

Display

This section allows to change how spectra are displayed in the spectrum view (blue box in Figure
2.1).

X
Selects the spectral domain:

• wavelength in nm

• wavenumber in 1/cm

Y
Selects what parameter to display on the vertical axis:

• Spectrum displays the spectrometer counts. If a background spectrum (page 7) has been
recorded, it is subtracted before display.

• Absorbance computes an absorbance spectrum 𝐴 = − log10
𝐼
𝐼0
, where I0 is a reference

spectrum (page 7)

• Transmittance computes an transmittance spectrum 𝑇 = 𝐼
𝐼0
, where I0 is a reference spec-

trum (page 7)

4 Chapter 2. Recording Spectra
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INFO-CIRCLE Note

The Absorbance and Transmittancemode require a reference spectrum (page 7).

Filter
Activates spectral post-processing to reduce noise (Figure 2.2). Available filters are:

• None: No filtering, the spectrum is left untouched.

• Moving Avg.: Amoving average7 filter.

• Binomial: A binomial (Gaussian)8 filter.

Order
Selects the window size of the moving average of binomial filter (Figure 2.2).

Fig. 2.2: Effect of Filter and Order.

Device Configuration Files

Device configuration (including multiple spectrometers (page 17)) can be saved to disk using File ‣
Save Configuration. Configuration files include:

• the connected spectrometers

• exposure parameters (page 4)

• intensity calibrations (page 9)

• external triggering (if supported)

• various device-dependent parameters (page 12)

To load a configuration file, use File ‣ Connect ‣ Load Configuration. An example configuration file
is displayed below (page 5).

{
”spectrometers”: [

{
”n_average”: 1,
”spectral_domain”: 1,
”intensity_calibration”: [

],
”use_intensity_calibration”: false,

(continues on next page)

7 https://en.wikipedia.org/wiki/Moving_average
8 https://en.wikipedia.org/wiki/Gaussian_filter

2.1. General Use 5
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(continued from previous page)

”intensity_calibration_unit”: ”W”,
”identifier”: ”Aris S/N 118”,
”use_nlir”: false,
”use_nlir_crop”: true,
”exposure_time”: 1.0,
”gain”: 0,
”external_trigger”: false,
”manufacturer”: ”Avenir”

}
]

}

INFO-CIRCLE Note

Background and reference spectra (page 7) are not saved in the device configuration but can be
saved and loaded from disk using the save dialogue (page 11) and saving in the .hdf5 format.

2.1.3 Recording Spectra

To record a single spectrum, click Single in the top bar (page 4). To continuously acquire spectra,
click Acquire, to stop spectral acquisition, click Stop.

Exclamation-Triangle Warning

Spectra will not be saved during continuous acquisition. To acquire spectra continously at reg-
ular time intervals, use a time-lapse acquisition (page 19).

2.1.4 Saving Spectra

To save the currently displayed spectrum, click the + button at the bottom of the sidebar. This will
add the spectrum to the sidebar. In the sidebar, you can:

• select several spectra (using Ctrl+Click or Shift+Click) to display in the spectrum view,
e.g. for comparison

• change the name of a spectrum by double-clicking on the spectrum’s name

• change the spectrum’s color by double-clicking on the color

• delete spectra by

– pressing the Delete key

– right-clicking on the selected spectra and selecting Delete from the context menu

• reorder spectra using drag&drop

• copy the selected spectra’s data to the system clipboard in the .csv format using Copy or
Control-C

• duplicate spectra by selecting Duplicate from the context menu

• reprocess spectra selecting Reprocess from the context menu

INFO-CIRCLE Note

Saved spectra are immutable. To change a spectrum, e.g. using filtering (page 5), background
subtraction (page 7) or by changing its spectral domain (page 4), select Reprocess from the context

6 Chapter 2. Recording Spectra
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menu. To perform reprocessing on a copy (to leave the original spectrum untouched), select
Duplicate followed by Reprocess.

To save the selected spectra, select Save from the contextmenu. See the section File Input & Output
(page 11) for details. To select all spectra, use Control-A.

Lightbulb Hint

If more than two spectra are selected, the Colorize option will become available. This allows
applying a color scale to differentiate the selected spectra, which can be useful to highlight
spectral differences of spectra acquired under different conditions (Figure 2.3)

Fig. 2.3: Colorizing Traces

Background & Reference Spectra

• to select a saved spectrum as the background spectrum, check the BG column in the spectra
sidebar (page 6). The intensity values of the background spectrum will be subtracted from
all subsequent recorded spectra.

• to select a saved spectrum as the reference spectrum, check the Ref. column in the spectra
sidebar (page 6). This will enable Absorbance (page 4) and Transmittance (page 4) calcula-
tions.

Lightbulb Tip

Meaningful background and reference spectra have to be acquired under experimental condi-
tions similar to the acquat spectral recordings, e.g. using the same exposure time and illumina-
tion. To improve the signal-to-noise ratio of background or reference spectra for subsequent
calculations:

• use averaging (page 4) during recording

• use filtering (page 5) to reduce noise by post-processing.

2.1.5 Spectrum Display

The spectrum view (blue box in Figure 2.1) displays one or more selected spectra. The view can be
adjusted

• using the scroll wheel to zoom

• dragging while holding down the right mouse button to zoom

2.1. General Use 7
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• dragging while holding down the left mouse button to pan

To reset the display (autoscaling all traces)< click the A button at the bottom left corner.

Additionally, the context menu (right-click) offers the following options:

• View All: autoscales the view

• X Axis and Y Axis adjust the visible X and Y range ad allow autoscaling one axis only

• Cursor. Displays a cursor or region-of-interest selector

– the Cursor (Cursor ‣ Cursor) is a vertical bar that can be dragged using the mouse. The
position of the cursor (x value) and the spectral intensity at the selected position (y value)
are displayed at the bottom of the TII Spectrometry window (Figure 2.4).

– the region-of-interest (ROI) selector (Cursor ‣ Region) marks a region that can be dragged
and resized using the mouse. Various parameters of the selected region are displayed
at the bottom of the TII Spectrometry window (Figure 2.4). For details on how the
parameters are computed, see Section 3.1.

(a) Cursor (b) ROI

Fig. 2.4: Spectrum View - Cursor Display

• Show Peaks toggles peak position display in the spectrum view (Figure 2.5)

Fig. 2.5: Peak Display

• Acquisition Parameters displays the Acquisition Parameterswindow (Figure 2.6), which contains
metadata of the acquired spectrum.

8 Chapter 2. Recording Spectra
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Fig. 2.6: The Acquisition Parameters Window.

• Export displays the Export Dialog window (Figure 2.7). This window allows:

– the export of the plot as an image

– the export of the plot’s underlying data as .csv or .hdf5

to disk or the system clipboard.

Fig. 2.7: The Export Dialogue Window

Lightbulb Hint

The spectrum view graph can also be copied to the system clipboard using standard sys-
tem commands (e.g. Control-C on Windows).

Pause-Circle Important

The .hdf5 files exported using the Export Dialogue cannot be re-imported into TII Spec-
trometry. For round-tripping, use the Save command (page 7) in the spectrum sidebar
(page 6).

2.1.6 Intensity Calibration

Intensity calibration describes the process of using a spectrum of a reference light source with a
a known intensity distribution (typically a black-body emitter with a well-characterized color tem-
perature) to correct the sensitivity and throughput of the spectrometer and input optics at dif-
ferent wavelengths. If the radiance or irradiance of the light source are known, recorded spectra
can, in addition, be made fully quantitative, which is essential for many applications of radiometry
(page 29). To calibrate a spectrometer:

1. record a spectrum of the reference light source (using appropriate acquisition settings
(page 4) and, if required, background subtraction (page 7))

2.1. General Use 9



TII Spectrometry

Pause-Circle Important

Since the calibration curve will be calculated by division using the intensity of the refer-
ence lightsource and the reference spectrum, a high signal-to-noise ratio of the calibra-
tion spectrum is advisable.

2. select Spectrometer ‣ Intensity Calibration ‣ Calibrate to display the calibration window (Figure
2.8)

Fig. 2.8: The Calibration Window

3. The spectrum of the reference light source is displayed in the left-most graph. To load the
reference intensity data, click the Load button and select the reference data

Pause-Circle Important

• reference data is expected to be in a two-column .csv format (Listing 2.1) with no
header.

Listing 2.1: Sample calibration data

193.00 0.0000E+000
193.50 0.0000E+000
194.00 0.0000E+000

Here,

– the first column contains the wavelength in nanometers or wavenumber in 1/cm

– the second column contains the reference value of the light source, e.g. spec-
tral power in W.

• the spectral range of the reference data is expected tomatch (or exceed) the spectral
range of the recorded reference spectrum. This means that the spectral domain
(wavelength or wavenumber) has to match as well

• the reference data will be interpolated to match the sampled wavelengths of the
recorded spectrum

4. The reference intensity data will be displayed in the center graph.

5. Select the unit of the reference intensity

10 Chapter 2. Recording Spectra
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6. The calibration curve (sensitivity curve) will be displayed in the right-most graph

7. Click Save to accept the calibration.

INFO-CIRCLE Note

The sensitivity curve is normalized by the exposure time. This means the exposure time can be
varied during subsequent spectral acquisitions to achieve the desired signal-to-noise ratio or
to avoid saturating the detector…

To use the intensity calibration, check Spectrometer ‣ Intensity Calibration ‣ Apply. The intensity
calibration will be applied to subsequently recorded spectra.

Lightbulb Hint

Calibration data can be saved in a device configuration file (page 5) so this procedure only has
to be reperformed if the optical setup changes.

SHARE See also

See the appliction example The Solar Spectrum (page 47) for additional hints and information.

2.1.7 File Input & Output

Spectral data can be exported from TII Spectrometry in a variety of ways:

• selecting one or more spectra in the spectrum sidebar (page 6) and selecting Copy from the
context menu (or using the shortcut Control-C) copies the spectral data to the system clip-
board using the .csv format. This allows direct pasting into third-party graphing or analysis
software.

• selecting one or more spectra in the spectrum sidebar (page 6) and selecting Save from the
context menu (or using the shortcut Control-S) displays a file dialogue and allows saving
the spectral data to disk. Available formats are .csv and .hdf5.

– .csv9 files enjoy widespread support and can be imported by virtually all third-party
software

– .hdf510 files are the native file format of TII Spectrometry and can be re-imported for
later analysis. These files can be read using a wide variety of applications includingMAT-
LAB11, Igor Pro12, and Origin Pro13. Python support is available via the h5py14 package.
In addition to the wavelength and intensity data, this format also contains

* raw intensity values (before background subtraction etc.)

* timestamps

* additional metadata

Lightbulb Tip

A convenient way to inspect .hdf5 files is the https://myhdf5.hdfgroup.org/ website.

9 https://en.wikipedia.org/wiki/Comma-separated_values
10 https://en.wikipedia.org/wiki/Hierarchical_Data_Format
11 https://www.mathworks.com/products/matlab.html
12 https://www.wavemetrics.com/products/igorpro
13 https://www.originlab.com/
14 https://docs.h5py.org/en/stable/

2.1. General Use 11
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• using the Export Dialogue (page 9) in the spectrum view.

INFO-CIRCLE Note

The recommended output format is .hdf5 exported from the spectrum sidebar (page 6), which
retains most information.

To re-import .hdf5 data into TII Spectrometry,

• use File ‣ Load Data and select a .hdf5 file from the file dialogue

• drag and drop one or more .hdf5 files onto the spectral sidebar

2.2 Supported Devices

This section contains information on specific spectrometers supported by TII Spectrometry. For
guidance on general use common to all supported devices, see Section 2.1.

Pause-Circle Important

Not all spectrometers are supported on all platforms. For details, see Table 1.1.

2.2.1 Avenir Photonics

TII Spectrometry supports the Avenir Photonics15 Aris (visible) and Siena (near-IR) spectrometers.
In addition to the standard spectrometer settings (page 4), the following settings are available in the
Spectrometer menu:

LED
Toggles the spectrometer’s LED

Auto
Activates auto-exposure mode

External Trigger
Activates external triggering

Gain
(Avenir Siena only) sets the gain

NLIR
activates NLIR Spectrum upconverter (page 16) support

In addition, the Burst Time-lapse Recording (page 22) window contains the following settings:

Data Format
Changes the data format of the spectrometer for higher throughput.

• 32bit float

• 16bit Int

• 16bit Int (Half Spectral Resolution)

The default (32bit float) has the highest resolution and fidelity. To increase the spectral ac-
quisition rate and to avoid filling up the spectrometer’s internal buffer, a more compact data
format (16bit Int or 16bit Int (Half Spectral Resolution)) can be selected. The effect of this set-
ting can be seen in Figure 2.9: When using the 32bit float format (blue), the spectrometer
buffer fills up after approximately 180 spectra and the spectral acquisition rate slows down

15 https://www.avenirphotonics.com/

12 Chapter 2. Recording Spectra
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from 250 Hz to 125 Hz. For the 16bit Int (Half Spectral Resolution) setting (red & green), the
spectrometer can continuously operate at full speed.

Fig. 2.9: Sustained spectral acquisition rate of an Avenir Aris spectrometer

2.2.2 ARCoptix

TII Spectrometry supports ARCoptix16 FTIR (FT-NIR and FT-MIR) spectrometers. Theses devices
are based on a scanning Michelson interferometer and cover spectral ranges in the near and mid
infra-red.

INFO-CIRCLE Note

ARCoptix spectrometers rely on a serverlet application that runs in the background. If the
application is not already running, it will be started by TII Spectrometry. The initialization of
this application as well as connection to and configuration of the spectrometer can take several
10s of seconds. In principle, connection to the serverlet application is also possible using over
a network connection - see the section Remote Connections (page 15) for details.

Pause-Circle Important

Since the scan rate of the interferometer is fixed, no exposure time settings are available.

The Spectrometer menu contains the following options:

Apodization

Selects an apodization function17 to remove high-frequency noise at the expense of a re-
duced spectral resolution

Interferogram
Toggles the display of the raw interferogram data (bottom of Figure 2.10).

16 https://arcoptix.com/Spectrometers.htm
17 https://en.wikipedia.org/wiki/Apodization

2.2. Supported Devices 13
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Fig. 2.10: The interferogram view

SHARE See also

See Section 5.1 (Fast Fourier Transform (FFT) Applied to FTIR Data (page 61)) for guidance on
how to analyze interferogram data.

Gain
Selects the gain of the spectrometer

Resolution
Selects the spectral resolution in 1/m. Higher numbers increase the scan speed but lower
the spectral resolution by decreasing the scan range of the interferometer (Figure 2.11).

Fig. 2.11: Spectral acquisition rate vs resolution

Exclamation-Triangle Warning

Changing the spectrometer resolution will reconfigure and disconnect the spectrome-
ter from TII Spectrometry. To continue using the spectrometer, simply connect again
(page 4).
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Remote Connections

Connections to the ARCoptix serverlet applications are possible over a network connection pro-
vided the computer running the serverlet application (‘host’ ) and the computer running TII Spec-
trometry (‘guest’ ) are part of the same subnet.

To establish a network connection:

1. on the host computer:

• connect the spectrometer to a USB port

• start the serverlet application:

– on Windows, this is done by starting AoDAQWin.exe

– on Linux, this is done by running AoDAQ_**, where ** indicates the suffix for the
file version and operating system

Lightbulb Tip

Use AoDAQWin.exe -h (on Windows) for help. It may be helpful to:

• run the application in verbose mode using AoDAQWin.exe -v for troubleshooting

• manually set a port number for the TCP/IP connection using, e.g. AoDAQWin.exe
-p 4711

2. on the guest computer:

• start TII Spectrometry

• open the Device Manager (page 18) using File ‣ Connect ‣ Device Manager

• enter the IP address and port number of the host computer and activate the ARCoptix
(remote) device

Lightbulb Tip

The default port number is 1424.

• click OK to establish the connection

INFO-CIRCLE Note

Remote and local spectrometers can be mixed - see Section 2.3 Using Multiple Spectrometers
(page 17) for details.

2.2.3 StellarNet

TII Spectrometry supports StellarNet18 spectrometers. In addition to standard spectrometer set-
tings (page 4), the following settings are available in the Spectrometer menu:

X-Timing
Sets the X-timing

Temperature Compensation
Toggles temperature compensation using dark pixels to increase spectrometer stability dur-
ing long recordings.

18 https://www.stellarnet.us/
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NLIR
activates NLIR Spectrum upconverter (page 16) support

Fig. 2.12: StellarNet spectrometer timing

2.2.4 NLIR Spectrum

The NLIR Spectrum19 is a wavelength converter that uses sum-frequency generation (SFG) of a
1064 nm laser (𝜆pump) withmid-infrared light (𝜆MIR) in a non-linear crystal for spectral upconversion
of the 1900-5300 nm mid-IR spectral range to the 682-886 nm visible range (𝜆NIR) (2.1).

1

𝜆NIR
=

1

𝜆MIR
+

1

𝜆pump
(2.1)

This device can be connected to supported spectrometers for recording MIR spectra using a
VIS-NIR device. The NLIR Spectrum is supported if the spectral range of the connected spectrom-
eter includes the output range of the upconverter (682-886 nm). In this case, the Spectrometer
menu will include the Spectrometer ‣ NLIR submenu.

Use
Toggles spectral re-conversion using (2.1) solving for 𝜆MIR. The spectral axis will hence be in
units of the original mid-IR light before upconversion.

Crop
Removes the spectral region outside of the upconversion output range.

The effect of these two settings is displayed in Figure 2.13: The bottom axis shows the wavelength
of the upconverted spectrum, the top axis shows the wavelength of the original light before up-
conversion. The green region marks the spectral range of the wavelength converter - spectra will
be cropped to this region if Crop is enabled.

19 https://nlir.com/products/wavelength-converters/spektrum/
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Fig. 2.13: Spectral output of the NLIR Spectrum wavelength converter

2.2.5 NLIR Midwave

The NLIR Midwave20 is a combination of NLIR spectral upconverter (page 16) and spectrometer.
In addition to standard spectrometer settings (page 4), this device also allows external triggering,
which can be activated using Spectrometer ‣ External Trigger ‣ Use External Trigger. The trigger edge
(rising or falling) can be selected using Spectrometer ‣ External Trigger ‣ Trigger Edge. Spectra are
automatically re-converted to the MIR range.

2.3 Using Multiple Spectrometers

TII Spectrometry supports the simultaneous control of multiple supported spectrometers . This
can be useful in the following scenarios:

• to combine spectrometers monitoring a single source with adjacent spectral ranges to ex-
pand spectral coverage. This used in the application example ‘The Solar Spectrum (page 47)’

• to use multiple spectrometers (with identical or different spectral coverage) to monitor sev-
eral processes simultaneously

20 https://nlir.com/products/spectrometers/midwave/
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(a) VIS + 2x MIR (b) VIS + NIR + MIR (Combined Spectrum)

(c) VIS + NIR + MIR (Split)
(d) 2x VIS + NIR + MIR (Time-lapse)

Fig. 2.14: Using multiple spectrometers in TII Spectrometry

Examples for these applications are displayed in Figure 2.14. There are no limitations on the num-
ber or type of spectrometers that can be controlled simultaneously in TII Spectrometry.

SHARE See also

See Table 1.1 for supported devices on different platforms and Section 2.2 for caveats applying
to individual device classes.

2.3.1 Device Manager

Fig. 2.15: The Device Manager

To connect tomultiple spectrometers, use the Device Manager (Figure 2.15), which can be accessed
using File ‣ Connect ‣ Device Manager. The Device Manager window will display all supported and
connected devices. To connect:

• enable the checkbox for the devices you would like to connect to

• click OK

18 Chapter 2. Recording Spectra
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SHARE See also

See Section 2.2.2 for details on remote connections to ARCoptix devices (page 15).

2.3.2 Use & Display Options

Connected devices will be displayed on the top bar (page 4) of the main window. Here:

• you can set the exposure time and averaging number for each device device individually

• use the checkbox to activate or (temporarily) deactivate one or more devices.

Two display options are available:

• the Combined view. Here, spectra from different devices are combined and displayed on
the same spectral axis. This is useful when using multiple spectrometers to expand spectral
coverage.

• the Split view. Spectra are displayed in separated graphs.

SHARE See also

Figure 2.14 shows examples for these two display modes.

• The Measure menu gives access to Time-lapse Recordings (page 20), which allows
software-synchronized time-lapse acquisitions using multiple spectrometers. In the
Time-Lapse window (page 20), you can switch between Combined and Split display using the
View menu.

• The Spectrometermenu gives access to spectrometer settings for each connected device, e.g
Intensity Calibration (page 9)

• recordings using multiple spectrometers can be processed (page 7), saved (page 6), and
loaded (page 11) from disk just like regular, single-device spectra.

• multi-spectrometer configurations (page 5) can be saved and reloaded.

2.4 Time-Lapse Recordings

In time-lapse recordings, spectra are recorded at regular intervals, e.g. to monitor a chemical
reaction. TII Spectrometry supports two time-lapse modalities:

1. regular time-lapse (page 20). Here, timing is controlled by the host PC and spectra are ac-
quired at a regular, user-defined interval. This mode

• supports software synchronization ofmultiple spectrometers (page 17) (Figure 2.16).

• spectra are updated in real time

On the other hand, this mode is unsuitable for high spectral acquisition rates and the
software-based timing makes some timing jitter unavoidable.

INFO-CIRCLE Note

While the maximum throughput of the regular time-lapse mode depends on the connec-
tion speed, CPU load and other factors, a good role of thumb is that the maximum rate
will be around 20Hz.

Time-lapse mode can be accessed using Measure ‣ Time Lapse, which shows the time lapse
window (page 21).
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Fig. 2.16: Time-lapse recording using multiple spectrometers

2. burst time-lapse recordings (page 22). Here,

• only a single spectrometer is supported

• graphical display is delayed or disabled until the recording is complete

• timing is left up to the spectrometer hardware

• if supported, spectra are buffered in spectrometer memory and read in bulk

This mode supports very fast acquisition rates > 1000 Hz (depending on spectrometer sup-
port). Burst recordings can be accessed using Measure ‣ Burst Acquisition

INFO-CIRCLE Note

Burst acquisitions are only available on selected spectrometers (Table 2.1)

Table 2.1: Burst Mode Availability

Avenir StellarNet NLIR Midwave ARCoptix

XXX XXX

Lightbulb Hint

Both time-lapse acquisition modes are compatible with external triggering (provided the spec-
trometer supports this) to carefully control timing and synchronization to an external signal.
In this case, the expected spectral interval (exposure time or cycle time) should be smaller than
the trigger interval.

2.4.1 Time-Lapse

Conventional time-lapse recordings can be accessed usingMeasure ‣ Time Lapse. In the time-lapse
window (page 21), the following parameters can be configured:

Interval Time
The time interval (in seconds between spectral acquisitions). This should be longer than the
exposure time (multiplied by the number of averages).

# of Spectra
The number of spectra to acquire
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Lightbulb Hint

Other parameters can be configured in the main window. This includes

• acquistion parameters (page 4) (exposure time, averaging)

• display and post-processing parameters (page 4)

The Acquire button starts the time-lapse acquisition, which can be aborted by pressing the Stop
button.

Fig. 2.17: The time-lapse window

In the time-lapsewindow (Figuee 2.17), the left pan contains the current spectrum. The right graph
contains a plot of a selected spectral parameter vs the acquisition time.

• the region of interest (blue box in the left graph) can bemoved and resized using themouse.

• the currently displayed spectrum can be selected by dragging the vertical marker in the right
graph

• the displayed parameter can be selected using the drop-down menu at the top right

SHARE See also

Please see the section on time-lapse analysis (page 23) for further details on parameter
computation.

• ifmultiple spectrometers are connected and active, a pair of spectrumand time-lapse graphs
is displayed for each spectrometer, see Figure 2.16 for an example.

Time-lapse recordings can be saved to disk using File ‣ Save. Available formats are .csv and .
hdf5. Time-lapse recordings saved in the .hdf5 can be re-imported using File ‣ Load for further
analysis in TII Spectrometry.

INFO-CIRCLE Note

The listing below displays an example time-lapse .csv file.
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Listing 2.2: The time-lapse .csv format

, 0.0, 0.1, 0.2, 0.3
328.385131836,-22.7980957031,38.7015953064,5.24367284775,32.3832092285
328.552246094,30.9543762207,14.3859844208,0.124359227717,89.9606399536

• the first row contains the timestamps in seconds.

• the first column contains the wavelength / wavenumbers

• the remaining columns contain the spectral intensity

2.4.2 Burst Recordings

For supported spectrometers, burst acquisitions can be accessed usingMeasure ‣ Burst Acquisition.
In the burst acquisition window (page 22), the following parameters can be configured:

Delay Time
Configures an additional wait time (inmilli-seconds) between exposures. The cycle time is the
sum of the delay time and the exposure + readout time. When external triggering is used,
the delay time is the delay between the trigger and the start of the exposure.

# Spectra
The number of spectra to record

As in software-controlled time-lapse recordings, other parameters can be configured in the main
window (page 4).

The Acquire button starts the time-lapse acquisition, which can be aborted by pressing the Stop
button.

Fig. 2.18: The burst acquistion window

The Settingsmenu gives access to the following options:

Settings ‣ Update Graph
When unchecked (the default), the display is only updated once the acquisition is completed.
If checked, graphs are updated at regular intervals (but not in real time).

Additional spectrometer-specific settings (page 12) also appear in the Settingsmenu.

Adjusting the displayed data, saving, and loading data is performed in the same fashion as for
conventional time-lapse recordings (page 21).
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THREE

ANALYSIS

3.1 Time-Lapse Analysis

Time-lapse analysis allows the visualization of the evolution of spectral parameters vs time. Avail-
able parameters are:

• Sum: a running sum of the selected spectral region 𝐼 =
∑︀𝑥1

𝑥0
𝐼𝑥

• Integral: the area under the curve of the selected region (computed by trapezoidal integra-
tion) 𝐼 =

∫︀ 𝑥1

𝑥0
𝐼𝑥𝑑𝑥. The difference to the Sum parameter is that the integral accounts for the

(potentially non-constant) spacing of the data points.

• Integral - BG: The area under the curve of the selected region after subtraction of the baseline.
The baseline is computed as the line connecting the borders x0 and x1 of the selected region.

• Height: The difference between theminimum andmaximum intensity of the selected region.

• Max. Location: The location (in units of wavelengths / wavenumber) of the point with the
highest intensity.

• Centroid: computes the centroid (center of mass) of the peak in the selected spectral re-
gion. For symmetric peaks, this is equal to the peak’s location, i.e. its highest value. Unlike
Max. Location, Centroid can interpolate the location and thus compute peak positions at a
resolution higher than the spectral resolution of the data. The center of mass is defined as:

𝑥COM =
∑︀

𝑥𝑖𝐼𝑖∑︀
𝐼𝑖

.

• FWHM: The full width at half maximum of the selected region.

• Ratio: The integrated intensity ratio of two selected regions (blue and green regions in Figure
3.1)

Fig. 3.1: Peak ratio analysis

• Ratio - BG: The integrated intensity ratio of two selected regions after subtracting the base-
line.
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• Load Model: Loads a pre-trained regression model (page 38) and uses this model to extract a
numerical value (e.g. a concentration based on a calibration curve) from the spectra (Figure
3.2). Several models can be loaded. Models appear in the menu using their file name.

(a) Model

(b) Prediction

Fig. 3.2: Timelapse regression analysis

Lightbulb Hint

Time traces can be exported by right-clicking on the (right) time trace view and selecting
Export to show the Export dialogue (page 9).

3.1.1 The Time-Lapse Analysis Window

The time-lapse analysis window can be accessed via View ‣ Analysis in the time-lapse window
(page 23). The analysis window has three panes:

1. the spectral image view (Figure 3.1). This view shows the acquired spectra as a spectral im-
age, with the spectral dimension as the horizontal axis, the elapsed time as the vertical axis,
and the spectral intensity as the image color.

• the current spectrum (shown at the bottom) can be selected by dragging the vertical
marker.

• the spectral region of interest can be selected by moving and resizing the vertical rect-
angle.

• the image color can be adjusted by dragging the markers in the top color scale
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Fig. 3.3: Time-lapse Analysis - Spectral Image

The vertical graph on the left displays a time trace of the selected parameter, similar to the
time lapse window (page 23).

2. the surface plot view (Figure 3.4). This shows a 3D representation of the time-lapse dataset
that can be rotated and zoomed using the mouse.

Fig. 3.4: Time-lapse Analysis - 3D surface

3. thewaterfall plot view (Figure 3.5). This plot ismore suitable for sparse time-lapse recordings
with only few acquired spectra. The (optional) coloring indicates time (in contrast to the 3D
surface plot where it represents intensity).
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Fig. 3.5: Time-lapse Analysis - Waterfall

Lightbulb Hint

The 3D surface and waterfall plots can be animated using the Animation settings box. Anima-
tions can be exported as .gif or .png using the Save button.

3.2 Colorimetry

Spectrophotometric Colorimetry21 describes the interaction of light with a sample across the en-
tire visible spectrum (typically 400 nm to 700 nm) to get a numerical representation of its color.
Colorimetry is available for all spectrometers operating in the visible range and can be accessed
using Analysis ‣ Colorimetry to show the Colorimetry window (Figure 3.6).

SHARE See also

See the application example Colorimetry of Light Sources & Color Charts (page 48) to see see
colorimetry in action.

Colorimetric analysis performs the following steps:

• raw spectral data (a spectral reflectance curve for opaque solids or a spectral transmittance
curve for transparent liquids/solids) is converted into colorimetric values that correspond to
how the human eye perceives color under specific lighting conditions (page 28)

• the spectral curve data is mathematically integrated with standard Observer functions
(page 28) (e.g., the CIE 1931 Standard Observer22) and standard Illuminant data (e.g., D65
for daylight) to calculate the 𝑋, 𝑌 , and 𝑍 tristimulus values. These values represent the per-
ceived amount of Red, Green, and Blue light, respectively. The Tristimulus Values (𝑋,𝑌, 𝑍)
are calculated by integrating the product of these three functions over the visible spectrum:

𝑋 = 𝑘
∑︁
𝜆

𝑅(𝜆)𝑆(𝜆)𝑥̄(𝜆)Δ𝜆

𝑌 = 𝑘
∑︁
𝜆

𝑅(𝜆)𝑆(𝜆)𝑦(𝜆)Δ𝜆

21 https://en.wikipedia.org/wiki/Colorimetry
22 https://en.wikipedia.org/wiki/CIE_1931_color_space
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𝑍 = 𝑘
∑︁
𝜆

𝑅(𝜆)𝑆(𝜆)𝑧(𝜆)Δ𝜆

Where:

– 𝑅(𝜆) is the measured spectral curve (from the spectrophotometer).

– 𝑆(𝜆) is the SPD of the chosen illuminant.

– 𝑥̄, 𝑦, 𝑧 are the CIE color matching functions.

– 𝑘 is a normalizing constant.

The 𝑌 value is particularly important, as it represents the sample’s absolute luminance or
lightness.

• The𝑋,𝑌, 𝑍 values are converted into the two chromaticity coordinates (𝑥 and 𝑦) using ratios:

𝑥 =
𝑋

𝑋 + 𝑌 + 𝑍

𝑦 =
𝑌

𝑋 + 𝑌 + 𝑍

and plotted in a chromaticity diagram (e.g. the CIE 1931 𝑥𝑦 Chromaticity Diagram), a 2D
projection that shows only the hue and saturation of a color, independent of its lightness
(luminance) (Figure 3.6 right panel).

• The 𝑋,𝑌, 𝑍 values are transformed into coordinates in a uniform color space like the CIE
𝐿*𝑎*𝑏* (Lab) space.

– 𝐿*: Lightness (0=black, 100=white).

– 𝑎*: Red/Green axis (+a=red, -a=green).

– 𝑏*: Yellow/Blue axis (+b=yellow, -b=blue).

• The CIE 𝑋,𝑌, 𝑍 Tristimulus Values are converted to RGB (Red, Green, Blue) for display on a
screen using the D65 white point.

Fig. 3.6: The Colorimetry window

The Colorimetry window is split into four sections (from top to bottom):

1. The top bar allows configuration of the illuminant (page 28) and color matching function
(page 28) used in the analysis

2. the color result view, which contains:

• a visual representation of the calculated color
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• color values in the RBG, HSL, and CIE 𝐿*𝑎*𝑏* color space

Lightbulb Hint

Color values can be copied using drag & drop.

3. The spectrum view, which shows the selected spectrum and (optionally) the selected illumi-
nant

4. the chromaticity diagram (page 27). The location of the selected spectrum in 𝑥𝑦 chromaticity
coordinates will be indicated by a circle. The outline of the circle corresponds to the color of
the selected spectrum (page 6).

Lightbulb Hint

Colorimetry works both in real time (live analysis while recording spectra) or post acquisition.
To analyse saved spectra:

• display the Colorimetry window

• select the spectrum or spectra in the spectrum side bar (page 6)

Multiple spectra can be analyzed simultaneously (see Figure 4.6 for an example).

The Colorimetry window (Figure 3.6) gives access to the following settings:

Color Matching Function
Selects a standard observer function

Illuminant
Selects the illuminant, the light source that was used to record the spectrum. Illuminants
include:

• standard incandescent illuminants with different color temperatures (A-D)

• fluorescent lamps

• LED illuminants

SHARE See also

See Figure 4.5 for an example of a LED illuminant.

Show
Toggles the display of the selected illuminant (page 28) spectrum in the spectrum plot (black
trace in the left panel of Figure 3.6)

Planckian Loci

Toggles the display of Planckian Loci23 (or Black Body Loci), a curved reference line in the
chromaticity diagram (page 27). This line represents the color of an ideal black-body radiator
as its temperature is increased from absolute zero up to infinity.

SHARE See also

See Section 3.3 on Radiometry (page 29) formore information, i.e. on the Correlated Color
Temperature (CCT).

23 https://en.wikipedia.org/wiki/Planckian_locus
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3.3 Radiometry

Unlike Colorimetry (page 26), which deals with the analysis of colors that originate from the
changes to the spectrum of a light source (‘illuminant’) by absorption or scattering of a sample,
radiometry involves the characterization of the light source itself. The Radiometry window (Figure
3.7), which can be accessed using Analysis ‣ Radiometry, provides the following functionality:

• measurement of the physical energy emitted by a light source in Watts

• measurement of the perceived brightness (page 30) of visible light (Lumens). Here, we are
taking radiometric data andweighting it according to the standardized human eye sensitivity
curve24 (V(𝜆)).

Pause-Circle Important

For the computed values of energy or brighntess to be physicallymeaningful, the spectrometer
has to be calibrated using a light source with

• a known spectrum

• a known power output

Tominimize geometric effects, the collection setup has to be carefully considered, for example
by using an integrating sphere.

For qualitative comparison of light sources and their quality, omitting this calibration step is
possible as long as the sensitivity curve of the spectrometer does not result in spectral distor-
tion in the visible range.

• characterization of light source color rendering quality from the spectral power distribution
(spectrum), e.g. color temperature (CCT) (page 32) or color rendering index (CRI) (page 32)

SHARE See also

See Section 4.3 - Radiometric Analyis of Light Sources (page 51) to see this in practice.

Fig. 3.7: The Radiometry window

The Ratiometry window (Figure 3.7) hosts the following controls / UI elements (from top to bottom):

1. the settings bar (page 30)

24 https://en.wikipedia.org/wiki/Luminous_efficiency_function
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2. the spectrum view

3. the Color Vector Graphic (page 31)

4. the result sidebar (page 32)

5. the quality metrics view (page 32)

3.3.1 The Settings Bar

The Settings bar offers the following settings:

Parameter
switches between Power (emitted energy) and Lux (perceived brightness) (Figure 3.8). To
compute the perceived brightness, the spectrum is multiplied by a standardized human eye
sensitivity curve V(𝜆)25, which is centered around 550 nm.

(a) Power (b) Lumen

Fig. 3.8: Energy vs perceived brightness

Start
The lower spectral bound used to determine the emitted power

End
The upper spectral bound used to determine the emitted power

Lightbulb Hint

The area used for integration is indicated by the shaded region in the spectrum view.

Accessory Display
Toggles the (optional) display of either:

• the reference illuminant used for calculating the color fidelity index 𝑅𝑓 and the color
gamut index 𝑅𝑔. For a color temperature (CCT) (page 32) < 5000 K, a theoretical Planck-
ian (black-body) radiator at that CCT will be used, for higher color temperatures, the
CIE Daylight distribution will be used. See Figure 4.7 for further examples of reference
illuminants.

• the raw spectral data (before intensity calibration)

Lightbulb Hint

Displaying the raw spectral data can be useful to judge how much of the dynamic
range of the spectrometer is actually used and to optimize acquisition parameters
to obtain a high-signal-to-noise ratio while avoiding saturating the detector.

25 https://en.wikipedia.org/wiki/Luminous_efficiency_function
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3.3.2 The IES TM-30-18 Color Vector Graphic

The Color Vector Graphic translates the numerical color quality data of a light source derived from
its spectral power distribution (SPD) into a visual map of color shifts. The graphic is a circular
plot that visually represents how a test light source changes the hue and saturation of colors
compared to an ideal reference source (like daylight or a black-body radiator). It is divided into 16
hue bins (sections around the circle), whichmakes it easy to identify deficiencies or enhancements
in specific color ranges (Figure 3.9).

Fig. 3.9: The Color Vector Graphic

This plot shows:

The Reference Ring
The central black circle in Figure 3.9 represents the chromaticity coordinates of the 99 Test
Color Samples (TCSs, also see Section 3.3.4) when illuminated by the reference source (the
ideal source for that color temperature).

The Test Vector
The red line in Figure 3.9 shows the average chromaticity coordinates of the TCSs in each of
the 16 hue bins when illuminated by the test light source.

By comparing the solid red line (test source) to the solid black line (reference source), one can
determine the light source’s local color rendering characteristics:

• Radial Distance (Saturation/Chroma Shift):

– Inward Shift: If the red line falls inside the black circle, the test light source is desaturating
(making duller) the colors in that specific hue bin.

– Outward Shift: If the red line falls outside the black circle, the test light source is over-
saturating (making more vivid) the colors in that hue bin. This shift is quantified by the
Color Gamut Index (R𝑔), which gives the average saturation shift

• Tangential Distance (Hue Shift):

– Clockwise Shift: The light source is shifting the perceived hue (the pure color) of objects
in that bin towards the next color in the clockwise direction (e.g., from green toward
yellow-green).

– Counter-Clockwise Shift: The hue is being shifted towards the next color in the
counter-clockwise direction.

While there is no single hue-shift metric, this visual distortion is captured within the
overall Color Fidelity Index (R𝑓 ) and the Local Color Fidelity (R𝑓,hue) for that bin.

In addition, the plot displays the following metrics:

Color Fidelity Index, R𝑓

Measures the color accuracy or fidelity of the light source on a scale from 0 to 100. It tells us
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how closely the colors of objects will appear to their “true” color as seen under the reference
light (usually daylight or a black-body radiator).

Color Gamut index, R𝑔

Measures the average increase or decrease in the saturation (chroma) of the colors rendered
by the light source on a scale from 0 to 100. This metric is crucial because light sources,
especially LEDs, can be designed to pump out intense light in specific wavelength bands
(like red and green) to make colors “pop,” even if the fidelity (Rf) isn’t perfect.

Correlated Color Temperature (CCT)
Indicates the color temperature of the light source in Kelvins (K). The CCT is calculated from
the light source’s 𝑋,𝑌, 𝑍 tristimulus values, which are then used to determine its Correlated
Color Temperature (CCT) from its position on the chromaticity diagram (page 27).

The Duv Value
Quantifies a light source’s chromaticity offset from the Planckian Locus

• a positive Duv indicates that the light source’s chromaticity is above the Planckian Locus.
This results in a greenish or yellowish-green tint.

• a negativeDuv indicates that the light source’s chromaticity is below the Planckian Locus.
This results a pinkish or magenta tint.

3.3.3 The Result Sidebar

The result section contains the calculated power and brightness. Here, you can also select which
color quality metric (page 32) to compute:

• Color Rendering Index (CRI)

• Color Quality Scale (CQS)

• Color Fidelity Index (CFI)

• Local Color Fidelity

• Local Hue Shift

• Local Chroma Shift

Results for the selectedmetric will be displayed at the bottom in addition to updating the test color
sample graph (page 33).

3.3.4 Color Quality Metrics

• Color Rendering Index (CRI)26, R𝛼, a score between 0 and 100 that measures the light source’s
ability to render colors accurately (Figure 3.10). The CRI is calculated using the CIE 2024 stan-
dard. The R𝑎 score (General CRI) is based on the first eight samples (R1 to R8).

INFO-CIRCLE Note

While standard, CRI is known to have limitations, particularly for LED lighting with sharp
spectral peaks, which can lead to a high CRI with poor appearance: A high R𝑎 value can be
achieved even if the light source is poor at rendering certain saturated colors (especially
deep red, R9, which is not included in the R𝑎 average).

• Color Quality Scale (CQS)27 (Figure 3.10). The CQS attempts to overcome limitations of the CRI,
in particular the use of de-saturated test colors, which allowed LEDs with narrow spectral
peaks (often missing deep reds) to score high while still rendering certain saturated colors
poorly. CQS uses 15 saturated colors, ensuring the test light source is properly evaluated
across the full color spectrum. The CQS is calculated using the NIST CQS 9.0 standard.

26 https://en.wikipedia.org/wiki/Color_rendering_index
27 https://en.wikipedia.org/wiki/Color_quality_scale
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• the IES TM-30-18 Color Fidelity Index (CFI)28 (Figure 3.10). This metric:

– uses 99 test colors

– separates fidelity (R𝑓 ) from gamut/saturation (R𝑔)

SHARE See also

The color vector graphic (page 31) is part of this analysis. Please see this section for a
discussion of the parameters R𝑓 and R𝑔.

• Local Color Fidelity (Figure 3.10), which compares the color fidelity accuracy across specific
hue bins around the color wheel. The hue bins are the same as in the color vector graphic
(page 31)

• Local Hue Shift and Local Chroma Shift reflect the hue / chroma differences compared to an
ideal emitter and correspond to the direction / magnitude of the arrows in the color vector
graphic (page 31).

The Test Color Sample Graph

The test color sample graph Figure 3.10 contains test color samples (TCS) in varying number and
color depending on which color quality metric was selected. The color of each bar indicates the
appearance of the test color sample as rendered considering the spectral distribution of the light
source.

(a) Color Rendering Index (b) Color Quality Scale

(c) Color Fidelity Index (d) Local Color Fidelity

Fig. 3.10: Comparison of Color Rendering Metrics for the LED lightsource in Figure 3.7.

SHARE See also

The (as of late) free tool BabelColor29 provides further radiometric analysis options.

3.4 Modeling

The Modeling package of TII Spectrometry allows to build and use predictive models to analyze
spectral datasets. Taking spectra as the input, two different kinds of analysis are available:

• Regression Analysis (page 37): Regression is used when the output property you want to pre-
dict is a continuous numerical variable, for example concentration, quality score, tempera-
ture, or moisture level. A typical example would be concentration prediction by using the

28 https://cie.co.at/publications/colour-fidelity-index-accurate-scientific-use
29 https://babelcolor.com/index.htm
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absorption spectrum of a chemical solution to predict the exact concentration of a solute,
often relying on the Beer-Lambert Law30.

• Classification Analysis (page 43): Classification is used when the output property you want
to predict is a discrete, categorical label or class, such as material type, defect presence,
or grade level. A typical example would be material identification: Classifying an unknown
plastic sample as Polypropylene (PP) or Polyethylene (PE) based on its IR spectrum.

The Modeling package is can be accessed using Analysis ‣ Modeling ‣ Train/Predict and is available
for any spectrometer.

SHARE See also

See the Application Example Plastic Identification (page 54) to see this in action.

3.4.1 General Overview

Details on Regression (page 37) and Classification (page 43) analysis will be discussed in dedicated
sections.

Both types of analysis, however, share a common workflow:

1. record a training dataset, e.g. spectra of known materials (for Classification) or of known
concentration (for Regression).

2. build a Model using this dataset (Training): This typically involves:

• assigning labels (numerical or categorical) to the dataset

• preprocessing (page 35) the data, e.g. by

– Baseline Correction: Removing unwanted background signal offsets.

– Normalization: Scaling the spectra to remove variations in overall light intensity or
path length.

– Smoothing: Reducing high-frequency noise.

– Cropping: Remove unnecessary spectral regions.

• training the model, e.g. using linear regression to fit a calibration curve

• validating the model

3. once the Model has been trained, it can be used for Prediction using unknown samples. The
model can also be saved to disk for later use.

Lightbulb Tip

Trained models can be used in TII Spectrometry in the following places:

• for real-time monitoring using both Classification and Regression models in the Monitor
(page 44) view.

• to extract a numerical value from spectra (using a Regression model) during time-lapse
recordings (page 23)

INFO-CIRCLE Note

In principle, signals from more than one spectrometer (page 17) can be incorporated into the
model, e.g. spectrometers

30 https://en.wikipedia.org/wiki/Beer%E2%80%93Lambert_law
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• covering different spectral ranges

• spectrometers measuring the same process at different locations

INFO-CIRCLE Note

Models, are, at least in principle, device-independent, which means that models trained on
spectral datasets of one spectrometer can be used for prediction using datasets of a different
device. The following caveats apply:

• spectra have to appropriately normalized to account for differences in device sensitivity
(this is best practice anyway)

• spectral ranges should (roughly) coincide and, crucially, include the spectral features that
are required by the model for discrimination. As a trivial example, a model trained on
near-IR data will (obviously) not work when using a spectrometer operating in the visible
range. For spectral ranges of suitable overlap, TII Spectrometry will use interpolation
and padding to transform spectral data and account for different spectral resolutions.

3.4.2 Pre-Processing

Pre-processing involves pre-treating the data to removenoise or scattering effects. Pre-processing
options are shared between regression and classification models and the same rationale applies
to both types of analysis.

INFO-CIRCLE Note

Pre-processing settings are part of the model. They will be saved in the model file and applied
to spectra during the Prediction phase.

TII Spectrometry offers the following pre-processing settings (Figure 3.11):

Fig. 3.11: Pre-processing Settings

Crop
Allows selecting a spectral subregion.

Baseline
Removes a non-linear baseline from the dataset using the Statistics-sensitive Non-linear Itera-
tive Peak-clipping (SNIP) algorithm (Ryan, 1988)31. The Extent parameter changes the curva-
ture of the baseline.

INFO-CIRCLE Note

31 https://doi.org/10.1016/0168-583X(88)90063-8
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A constant offset can easily be removed using Scaling (page 36). If the baseline can be re-
moved by background subtraction (page 7) during spectral acquisition, this is likely prefer-
able.

Filter
Applies a convolutional smoothing filter to the data. The settings are identical to the Filter
setting (page 5) in the main window.

Scaling
Scales (normalizes) the data. Three options are available:

• None: Performs no scaling

• Min-Max (page 36): Scales each spectrum in the range between 0 and 1.

• SNV : Applies Standard Normal Variate scaling (page 36).

Pause-Circle Important

Scaling is crucial for Regression or Classification performance and, in particular, to achieve
generalized models that are independent of:

• illumination conditions

• spectrometer sensitivity or exposure time

See Table 3.1 for a comparison of the scaling methods of TII Spectrometry.

Scaling Methods

Min-Max Scaling

Min-Max scaling, also known as feature scaling or unity-based normalization, is a data preprocess-
ing technique to transform numerical features to a specific, predefined range, usually [0, 1].

For a single spectrum 𝑋𝑖, the transformation is:

𝑋MM,𝑖 =
𝑋𝑖 −min(𝑋𝑖)

max(𝑋𝑖)−min(𝑋𝑖)

Here:

• 𝑋𝑖 is the original spectrum.

• min(𝑋𝑖) andmax(𝑋𝑖) are theminimumandmaximumabsorbance/reflectance values within
that single spectrum.

The primary goal of per-spectrum Min-Max scaling is to remove multiplicative scaling differences
caused by factors like changes in path length, sample packing, or light source intensity that affect
the magnitude of the spectrum.

• Baseline Anchor: This method forces the lowest point in the spectrum to 0 and the highest
point to 1. This effectively corrects for differences in the dynamic range or overall spread of
the signal intensity from one sample to the next.

• Contrast Preservation: It preserves the relative shape and proportionality of the spectral
features, ensuring that the height ratios between peaks remain consistent.

Standard Normal Variate Scaling

SNV scaling is a per-spectrum operation, meaning it is applied independently to each individual
spectral curve in a dataset. It is a two-step process that normalizes the spectrum based on its own
mean and standard deviation. The Standard Normal Variate (SNV) scaling method is a common
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technique used in spectroscopy, particularly with Near-Infrared (NIR) data, to perform baseline
correction and standardize spectral features. For a single spectrum 𝑋𝑖 (a vector of measured
values at different wavelengths), the transformation to the scaled spectrum 𝑋SNV,𝑖 is given by:

𝑋SNV,𝑖 =
𝑋𝑖 − 𝑋̄𝑖

𝑠𝑖

Here:

• 𝑋𝑖 is the original spectrum.

• 𝑋̄𝑖 is the mean of all absorbance/reflectance values within that spectrum.

• 𝑠𝑖 is the standard deviation of all absorbance/reflectance values within that spectrum.

This formula results in a new spectrum where the average intensity is centered near zero, and the
variance (spread) is standardized to one.

SNV scaling effectively removes twomajor sources of variation that are not related to the sample’s
chemical composition:

1. Baseline Offset (Additive Effects): The subtraction of the mean (𝑋̄𝑖) corrects for constant ver-
tical shifts in the spectrum caused by factors like changes in the sample path length or light
scattering variations that affect the overall intensity level equally across all wavelengths.

2. Scaling Differences (Multiplicative Effects): Dividing by the standard deviation (𝑠𝑖) corrects
for variations in the slope or overall magnitude of the spectrum caused by differences in
scattering properties, particle size, or instrument changes.

By removing these physical variations, SNV enhances the spectral features that are genuinely re-
lated to the chemical composition (the characteristic absorption peaks), making subsequent mod-
eling more accurate and robust.

Table 3.1: Min-Max vs. SNV

Feature Per-Spectrum Min-Max Scaling Standard Normal Variate (SNV)

Cen-
tering
Refer-
ence

The absolute minimum value of
the spectrum.

Themean value (𝑋̄𝑖) of the entire spectrum.

Scaling
Refer-
ence

The range (max−min) of the spec-
trum.

The standard deviation (𝑠𝑖) of the spec-
trum.

Tar-
geted
Error

Primarily Multiplicative scaling (in-
tensity differences).

Both Additive baseline shifts and Multi-
plicative scaling.

Effect
on
Peaks

Anchors the lowest point to 0 and
stretches/compresses the peaks to
fit between 0 and 1.

Centers the whole spectrum around 0, mak-
ing the negative and positive peak areas
equivalent in deviation.

SHARE See also

See the Application Example Plastic Identification (page 54) for a discussion of data preprocessing
in the context of a pratical application.

3.4.3 Regression Analysis

As discussed above, Regression involves assigning numerical values to spectra.

TII Spectrometry offers two different methods to train Regressionmodels (Table 3.2):
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• manual training using linear regression32. This requires the selection of a relevant spectral
feature, e.g. the area of a peak or the intensity ration of two peaks, from which a calibration
curve is constructed. Prediction is performed using this calibration curve.

• semi-automated, machine-learning based regression based on Support Vector Regression
(SVR)33. In contrast linear regression, which try to minimize the sum of squared errors, SVR
tries to fit the best line or hyperplane while ensuring that most of the predicted data points
are within a certain distance of that line. For non-linear relationships (which are common in
spectral datasets), SVR uses the Kernel Trick (e.g., the Radial Basis Function or RBF kernel)
to map the input features into a higher-dimensional space where a linear hyperplane can
successfully model the non-linear relationship in the original space. This method is not only
robust to noise and outliers but also can model complex, non-linear relationships between
spectral features and continuous properties (like concentration or quality scores) using ker-
nels. In contrast to linear regression, no feature selection by the user is required.

Table 3.2: Linear Regression vs. SVR

Feature Linear Regression Support Vector Regression (SVR)

Model
Type

Parametric (Assumes a linear rela-
tionship).

Non-Parametric (Flexible, often uses ker-
nels).

Objec-
tive
Func-
tion

Minimizes the Sum of Squared
Errors (SSE), penalizing all errors
equally.

Minimizes the errors that fall outside a de-
finedmargin (𝜖), ignoring small errorswithin
the margin.

Error
Treat-
ment

Sensitive to all data points and out-
liers, especially those far from the
line.

Insensitive to data points within the 𝜖-tube;
robust to noise and outliers.

Model
Com-
plexity

Simple, easy to interpret, fast to train. More complex, computationally intensive,
especially with kernel methods.

Non-LinearityCannot model non-linear relation-
ships without manual feature engi-
neering (e.g., polynomial terms).

Naturally handles non-linear relationships
using the Kernel Trick (e.g., RBF kernel).

Key
Points

Finds the line that best fits the aver-
age of the data.

Finds the line that best fits theboundaryde-
fined by the Support Vectors.

Appli-
cation
Suit-
ability

Simple, well-behaved datasets where
relationships are known to be linear.

High-dimensional, complex datasets (like
spectral data) where non-linear modeling
and noise robustness are required.

Training

Linear Regression

The Train view (Analysis ‣ Modeling ‣ Train/Predict, Figure 3.12) contains the following user interface
elements:

• the spectra sidebar on the left, which contains the spectra used for training as well as their
labels

• the spectrum view, which contains the spectra after pre-processing

• the parameter sidebar on the right, which controls pre-processing and training settings

• the result view (center bottom), which contains the calibration curve and the predicted nu-
merical value for each training spectrum.

32 https://en.wikipedia.org/wiki/Linear_regression
33 https://en.wikipedia.org/wiki/Support_vector_machine
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Fig. 3.12: The Training view of the Modeling Window

To train a Regression Model:

1. display the Modeling window using Analysis ‣ Modeling ‣ Train/Predict (Figure 3.12).

2. select the Train tab (the Train tab is shown in Figure 3.12).

3. select Regression from the radio button set below the left sidebar

4. load a dataset. This can be done by:

• dragging spectra from the spectra side bar (page 6) into the left sidebar of the Modeling
window

• dragging a saved file (in .hdf5 format) onto the left sidebar

The spectra contained in the file will now appear in the sidebar and the spectrum view

5. apply numerical labels to each spectrum. This can be done by:

• double-clicking on the cell in the Value column

• entering a numerical value, e.g. a concentration

Lightbulb Hint

Since labeling can be tedious, labeled datasets can be saved using File ‣ Save Dataset.

6. select appropriate pre-processing (page 35) parameters.

Lightbulb Tip

The spectra in the spectra view will reflect the current preprocessing settings.

For the data in Figure 3.12 in we have :

• cropped the spectral range between 400 and 800 nm

• applied SNV scaling (page 36)

Pause-Circle Important
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Scaling is generally recommended for satisfactory model performance. Please see the
discussion in Section 3.4.2 for details.

SHARE See also

For this example, we are training a linear regression model (page 37), which requires manual
feature selection. For training a Support Vector Regression (page 38) model, jump forward to
Section 3.4.3.

Fig. 3.13: Linear Regression Settings

7. Figure 3.13 displays the settings for a linear regression analysis.

• Parameter: Allows the selection of a spectral parameter, e.g. an integral, peak width, or
peak area ratio. Please see Section 3.1 for available parameters and their definition.

• Start and End determine the spectral range from which the parameter is computed.
This parameter can also be adjusted by dragging and resizing the region selector in the
spectrum view.

• for peak ratios, the Start 2 and End 2 settings will become available

8. The Calibration Curve (bottom of Figure 3.12) will reflect the settings. Adjust settings until the
linear trendline matches the data.

• the table adjacent to the calibration curve shows the X and Y values of the curve

• slope, y-intercept, and R2 value are displayed in the calibration curve graph

9. If you are satisfied with the model, switch to the Predict tab (Section 3.4.3).

10. (optional) Save the model to disk using File ‣ Save Model.
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Support Vector Regression

Fig. 3.14: The Training view of the Modeling Window (SVR)

Loading data, assigning labels, and preprocessing are identical between linear regression and SVR
models (steps 1-6 in Section 3.4.3).

Fig. 3.15: SVR Settings

Figure 3.15 shows a close-up of the SVR settings box, which has two parameters:

C
The parameter 𝐶 controls the trade-off between model complexity and the degree of toler-
ance for training errors.

• A small 𝐶 means a weak penalty. The model allows more points to violate the margin,
resulting in a smoother, simpler hyperplane (higher bias, lower variance). This is often
desired if the data is very noisy.

• A large 𝐶 means a strong penalty. The model tries hard to include almost all training
points within the margin, resulting in a more complex, wiggly hyperplane (lower bias,
higher variance). This can lead to overfitting if the data is noisy.

𝜈 (Nu)
𝜈 places an upper bound on the fraction of training errors (outliers that fall outside the mar-
gin) and a lower bound on the fraction of Support Vectors relative to the total number of
training points. 𝜈 must be between 0 and 1. 𝜈 implicitly determines the value of 𝜖, which is
used in some SVM implementations.

• A small 𝜈 (e.g., 0.1): Allows for a tighter margin and fewer outliers. This corresponds to
the model being more restrictive, similar to a high 𝜖

• A large 𝜈 (e.g., 0.9): Allows for a wider margin and more potential outliers/Support Vec-
tors.

Fit
Click the Fit button to train the model. This will update the result graph and result table.
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The SVR algorithm automatically extracts the relevant spectral features for regression from the
dataset. The resulting curve is shown in at the bottom of the Train window (page 41). The curve
displays the assigned (Input) vs Predicted numerical value - ideally this should be a straight line
with slope 1 and datapoints should coincide with the black line. The table on the right side of the
graph displays the numerical values of the assigned labels.

Prediction

To use a model, select the Predict tab (Figure 3.16).

Fig. 3.16: The Predict screen (SVR)

The Predict tab will contain the last trained model from the Train tab. Alternatively, you can load a
model from disk using File ‣ Load Model.

Lightbulb Tip

You can switch back and forth between the Train and Predict screens to optimizemodel training
using cross-validation.

To use a model:

1. load data by dragging a .hdf5 file onto the left sidebar. This will:

• open the spectra

• apply the processing selected in the model

• perform the regression analysis

2. the results can be found in the table at the bottom. It contains:

• the predicted numerical value

• the name of the spectrum

In the example in Figure 3.16, the spectra were recorded at known concentrations so this dataset
can be used for validation. The concentrations in the validation dataset are different from the
concentrations employed during training. The Name column contains the (known) correct value
of the predicted parameter. It can be seen that the agreement between predicted and correct
validation value is very good, which indicates that we have successfully trained the model.

INFO-CIRCLE Note

For linear regression models (page 38),
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• the result table in the Predict screen also contains the extracted spectral parameter (e.g.
integrated peak are) in the Y column

• the Predict screen displays the calibration curve and the position of the of the samples on
the curve.

See Figure 3.17 for an example.

Fig. 3.17: The Predict screen (Linear Regression)

3.4.4 Classification Analysis

For Classification, TII Spectrometry offers Support Vector Machine (SVM)34 Classification. Anal-
ogous to Support Vector Regression (SVR) (page 38), the goal of SVM classification is to find the
hyperplane that has the largest margin between the nearest training data points of any class.

SHARE See also

Many of the remarks on Support Vector Regression (page 38) also apply to SVM classification.

Training

Training a Classificationmodel generally mirrors the steps laid out in Section 3.4.3:

1. display the Modeling window using Analysis ‣ Modeling ‣ Train/Predict (Figure 3.18).

2. select the Train tab (the Train tab is shown in Figure 3.18).

3. select Classification from the radio button set below the left sidebar

4. load a dataset.

5. apply labels to the dataset. Labels can any text.

Lightbulb Tip

Labeled datasets can be saved to disk

6. adjust the SVM hyperparameters 𝐶 and 𝜈 (Section 3.4.3) and click Fit to train the model.

7. the result view at the bottom shows the confusion matrix35, which plots the predicted vs.
assigned label. Ideally, all values fall on the diagonal.

8. if you are satisfied with the model, switch to the Predict (page 44) tab.

34 https://en.wikipedia.org/wiki/Support_vector_machine
35 https://en.wikipedia.org/wiki/Confusion_matrix
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Fig. 3.18: Training a Classificationmodel.

Prediction

Using a trained classificationmodel for prediction mirrors the use of regressionmodels (page 42).

Simply:

1. Load a dataset by dropping a .hdf5 file onto the left sidebar.

2. The classification result will be shown in the table at the bottom (Figure 3.19)

Fig. 3.19: Using a Classificationmodel.

For the dataset in Figure 3.19, the first part of the name of the spectra used for prediction contains
the correct label. It can be seen that the agreement of the predicted value with the correct label
is excellent.

3.4.5 Monitoring

You can use trained models (both Classification and Regression models) in TII Spectrometry for
real-time monitoring, for example:

• to monitor a concentration using a Regressionmodel

• to identify different substances

This functionality can be accessed using Analysis ‣ Modeling ‣Monitor to show theMonitoring screen
(Figure 3.20). Here,

• you can load a model using the Load button
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Whenusing the spectrometer in single or continuous acquisitionmode (page 4), the prediction result
of the selected model for the currently acquired spectrum will be shown in the top right.

Pause-Circle Important

The prediction results are only displayed but not saved to disk. To record prediction results,
use a time-lapse acquisition (page 23).

Fig. 3.20: Real-time monitoring (snapshots)

Figure 3.20 displays snapshots of the prediction result at different points in time. The dataset
/ model used in this experiment (which contains many different sample classes) is displayed in
Figure 3.21. It is important to note that:

• the signal-to-noise ratio of the test spectra (during monitoring) is a lot lower than the SNR
of the spectra used for training. Due to appropriate scaling and the relatively noise-tolerant
SVM model, this has no detrimental effect during the prediction stage.

• prediction fidelity is excellent - there are no misclassifications
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Fig. 3.21: The Classificationmodel used for the monitoring experiment.
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CHAPTER

FOUR

APPLICATION EXAMPLES

4.1 The Solar Spectrum

Spectral calibration is also relevant whenmultiple spectrometers (page 17) with overlapping or ad-
jacent spectral ranges are used to record the spectrum of the same light source (see scheme in
Figure 4.1). Figure 4.3 displays the spectrum of the sun using two spectrometers that cover the
visible and near-infrared range of the solar spectrum.

Fig. 4.1: Measuring the spectrum of the sun using two spectrometers

Both spectrometers (page 12) (and their input fibers) were calibrated using the same reference light
source according to the procedure outlined in Section 2.1.6 (Intensity Calibration (page 9)).

1. The spectrum of a reference light source (incandescent lamp with a color temperature of
2600 K) was acquired using both spectrometers (Figure 4.2 left). The decrease in sensitivity
at NIR wavelengths of the VIS spectrometer (700-800 nm) is clearly visible. It is obvious that
the spectrum doesn’t match the expected shape of a tungsten lamp at all.

2. The reference intensity curve was calculated using the known color temperature of the ref-
erence light source in the spectral range between 200-3000 nm using Planck’s Law36 (4.1).

𝐼 =
2ℎ𝑐2

𝜆5

1

exp( ℎ𝑐
𝜆𝑘𝐵𝑇 )− 1

(4.1)

Here, h is Planck’s constant, c is the speed of light, kB is Boltzmann’s constant, T is the absolute
temperature of the black body emitter, and 𝜆 is the wavelength.

3. The calibration data was applied to the two spectrometers. This results in a
intensity-corrected spectrum of the reference light source (Figure 4.2 right).

36 https://en.wikipedia.org/wiki/Planck%27s_law
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(a) Before Calibration (b) After Calibration

Fig. 4.2: Calibrating two spectrometers

After intensity calibration of both spectrometers, the recorded spectrum of the sun (Figure 4.1)
matches that of a black body emitter with a color temperature > 5000 K (deviations are due to
atmospheric scattering, which increase when the input fiber is pointed away from the sun). Fraun-
hofer lines are visible in the spectrum. Fraunhofer lines are a set of dark spectral absorption lines
observed in the continuous spectrum of the Sun and other stars that reveal the chemical com-
position of stellar atmospheres. Note that some dark lines, like the A and B bands, are Telluric
lines, meaning they are caused by absorption by molecules (primarily oxygen (O2) and water va-
por (H2O)) in the Earth’s own atmosphere, rather than the Sun’s.

(a) Spectrum

(b) Fraunhofer Lines

Fig. 4.3: The spectrum of the sun

SHARE See also

The solar spectrum will be further analyzed in the Application Examples Radiometric Analyis of
Light Sources (page 51) & Colorimetric Analysis of the Spectrum of the Sun (page 49).

4.2 Colorimetry of Light Sources & Color Charts

This section provides practical tips and tricks as well as some application examples on colorimetric
analysis. See Section 3.2 for background and a description of the parameters and user interface.
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4.2.1 Colorimetric Analysis of the Spectrum of the Sun

We can re-use the spectra obtained in Section 4.1 (The Solar Spectrum (page 47)) for colorimetric
analysis. Here, we are using the illuminant E (page 28), which is a flat curve (black trace in Figure
4.4), since spectra were obtained from an emissive source. Only the visible region of the spectrum
is used for analysis and hence the majority of the spectrum, which falls into the mid-IR range, is
ignored.

Fig. 4.4: Colorimetric Analysis - Spectrum of the Sun

When the spectrometer input fiber pointed directly at the sun (gray trace in the left panel of Figure
4.4), the calculated color is a bright, slightly yellow-white, as expected. When light is collected in-
directly by pointing the input fiber away from the sun, the color shifts to a cool, bluish-white (blue
trace in the right panel of Figure 4.4), matching the expected blue color of the sky on a clear day.
The position in the chromaticity diagram (page 27) of both spectra coincides with the line of a black
body emitter (Planckian Loci (page 28), black line in the right panel of Figure 4.4). This means both
light sources (the sun itself and the scattered light from the sky) match the ideal color of a thermal
radiator. The spectrum of the sun (circle with gray outline) corresponds to a color temperature
of approximately 6000 K, which is a value typical for direct sunlight filtered by the atmosphere.
On the other hand, the spectrum of the sky (circle with blue outline) suggests a color tempera-
ture of almost 10000 K. This indicates that there is a significant amount of atmospheric scattering
(Rayleigh scattering 𝐼𝑠,Rayleigh ∝ 1/𝜆4) caused by the relatively low position of the sun in the sky due
to latitude and time of day. Since light at short wavelengths (blue light) is more effectively scat-
tered by air molecules than red light, atmospheric scattering will blue-shift the spectrum. This
matches the observations in Figure 4.3 that were obtained by comparing the raw spectra with the
expected curve of a black body emitter with the temperature of the sun (5800 K).

4.2.2 Reflective Colorimetric Analysis

In this section, spectra were obtained using a small, handheld spectrometer using light reflected
from a printed color sample. The sample was illuminated by LED lamps (room lighting of an of-
fice environment) and spectra were recorded by placing the entrance pupil of the spectrometer
close to the color sample at a shallow angle to the surface normal. The displayed spectra are the
raw data from the spectrometer; no dark / background subtraction (page 7) or intensity correction
(page 9) was performed.

Lightbulb Tip

For colorimetric analysis, the spectrum is analyzed in the range between 400-700 nm. If the
sensitivity curve of the spectrometer is not reasonably flat in this spectral range, performing a
intensity calibration (page 9) is recommended for best results.
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Fig. 4.5: Colorimetric Analysis - Illuminant

Figure 4.5 shows the spectrum reflected of an office desk with a bright white color. The black line
represents the LED-B4 illuminant (page 28), a brightwhite LED light sourcewith a color temperature
of 5100 K, which is typical for office settings. The two spectra roughly match, indicating that this
illuminant is a good choice to represent the light source used in this experiment. The calculated
color is a slightly yellowish gray, which reasonably matches the visual perception of the desk’s
color.

Fig. 4.6: Colorimetric Analysis

Figure 4.6 displays spectra obtained from different color samples (with the names taken from the
color sample’s description) in the left pane. All spectra have been normalized, which is automat-
ically done prior to analysis. Significant spectral differences even for perceptually ‘close’ colors
(e.g. green and lime) can be observed. Using the correct illuminant, the calculated color and visu-
ally perceived color match quite well over a wide range of different colors. Color fidelity could be
further improved by:

• standardized illumination

• more repeatable spectrum collection, i.e. avoiding specular reflections and shadowing, and
maintaining a constant reflection angle.

• intensity calibration, though the effect will likely be very minor

• an improved signal-to-noise ratio for some of the spectra
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4.3 Radiometric Analyis of Light Sources

This section describes the practical application of Radiometry (page 29) in the analysis of the emit-
ted power and color fidelity of different light sources.

The investigated light sources are:

1. an incandescent lamp with known output power that serves as the calibration source.

2. a warm-white LED lamp (Toshiba LDA8L-G37) with a nominal color temperature (page 32) of
2700 K and an R𝛼 (page 32) of 80

3. a cool-white LED (Panasonic LDA4DGK438) with a nominal color temperature of 6500 K and
an R𝛼 of 84.

LED light sources were mounted in an integrating sphere. The spectrometer was calibrated using
the procedure outlined in Section 2.1.6 using the incandescent calibration lamp, which is inte-
grated into the integrating sphere. The spectrometer’s exposure time was adjusted before each
light source change and after the calibration to avoid saturating the detector while maintaining a
acceptable signal-to-noise ratio. The results are shown in Figure 4.7 (the result for the cool-white
LED is shown without power calibration).

37 https://saturn.tlt.co.jp/pdocs/s/LDA8LG60W
38 https://www2.panasonic.biz/jp/catalog/lighting/products/detail/shouhin.php?at=keyword&amp;ct=zentai&amp;id=

S00327316
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(a) Incandescent

(b) LED (warm-white)

(c) LED (cool-white)

Fig. 4.7: Radiometric analysis of various light sources

4.3.1 Results - Color Quality

• the perceived brightness (page 30) of the warm-white LED (about 900 lm) slightly exceeds
the nominal value. This value gradually decreases as the LED heats up. It is likely that the
manufacturer’s specifications are minimum limits.

• the incandescent lamphas a color rendering index (CRI) (page 32) (R𝑎) close to 100, as expected
from the definition of the CRI. The (calculated) reference curve closely matches the spectrum

• the warm-white LED has a CRI (R𝑎) of 83, slightly exceeding specifications

• the cool-white LED has a CRI (R𝑎) of 83, slightly below specification

• the warm-white LED and the incandescent lamp have a similar color temperature (page 32)
and hence render the test color samples very similarly. The biggest exception is color #9
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(deep red), which is poorly rendered by the LED

• the cool-white LED shows a similar deficiency for color #9, but (as expected), the other colors
are rendered more realistically due to its higher CCT. This is particularly apparent for color
#13, which represents a typical skin tone.

• the color temperature of the cool-white LED (5700 K) is quite a bit lower than the specification.
It is not clear why this is the case, but it might be due to aging of the blue LED component.

• the 𝐷𝑢𝑣 value (page 32) for the incandescent lamp is close to 0. For the LEDs, the 𝐷𝑢𝑣 is
slightly positive, indicating a subtle greenish tint characteristic of white-pumped LEDs

• for the warm-white LED and the incandescent lamp, a (calculated) black-body emitter curve
is used as reference (page 30), while for the cool-white LED, the CIE Daylight data is used

Fig. 4.8: Radiometric analysis of the spectrum of the sun

We can compare this with the spectrum of the sun from Section 4.1, which is shownwithout power
calibration (Figure 4.8). Being a black-body emitter, the spectrum of the sun also has a CRI of 100
and a color temperature > 6000 K. The dips in the CIE Daylight reference spectrum nicely coincide
with the measured Fraunhofer lines (see also Figure 4.3). Comparing the sun with the cool-white
LED, which has a similar color temperature (page 32), shows that sunlight renders all test colors
with equally high fidelity, whereas the LED fails in particular at highly-saturated red (color #9).
The 𝐷𝑢𝑣 is, maybe surprisingly, quite high and comparable to the 𝐷𝑢𝑣 of the warm-white LED in
magnitude. This is likely a result of atmospheric scattering blue-shifting the solar spectrum.

4.3.2 Color Temperature & Planckian Loci

Fig. 4.9: Comparison of LED and incandescent light sources and their color temperature.
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Figure 4.9 shows a comparison of all four light sources (warm-white and cool-white LED, incan-
descent lamp, sun) in the colorimetry view (page 26). The positions of all four light sources (more
or less) fall on the curve of Planckian Loci (page 28), which indicates that they all match the spec-
tral characteristics of a black body emitter, albeit at different color temperatures. For the actual
black body emitters (the sun and the incandescent lamp, red and grey outlined circles), the co-
incidence is noticeably better compared to the LEDs (blue and green outlined circles). The LEDs,
being solid-state emitters, have discontinuous (peaked) spectral power distributions, which will al-
ways result in a measurable offset from the continuous Planckian Locus, even if their CCT is close.
The differences in color temperature and quality of a neutral test target is illustrated by the cal-
culated colors - sunlight clearly has the whitest, most neutral rendition whereas the lower color
temperature sources cause a significant warmer tint.

4.4 Plastic Identification

4.4.1 Mid-Infrared Spectroscopy

Mid-Infrared (Mid-IR) spectroscopy, operating in the 4000 cm-1 to 400 cm-1 wavenumber range,
is the gold standard for identifying and classifying different types of plastics. When mid-IR light
hits a plastic sample, the chemical bonds within the polymer chains (like C-H, C=O, and C-C bonds)
absorb energy at specific, characteristic frequencies. This absorbed energy causes the bonds to
vibrate (stretch, bend, rock, etc.). Since every type of plastic (e.g., Polyethylene, Polypropylene,
PET) has a unique combination and arrangement of these chemical bonds, it produces a distinct
pattern of absorption peaks. This pattern is called the infrared absorption spectrum or molecular
fingerprint.

The measurement setup for plastic identification is shown in Figure 4.10 (left panel).

• A mid-IR light source (top) illuminates the sample. Transmitted IR light is directly collected
by an FTIR spectrometer (page 13).

• Absorbance spectra are collected in the transmission geometry, meaning that thin plastic
films are placed directly in the beam.

• Absorbance was calculated using the procedure outlined in Section 2.1.4.

• single FTIR scans without averaging were acquired, resulting in a cycle time of around 200
ms.

• three household plastic samples were used: polystyrene (PS), polyethylene (PE), and
polypropylene (PP)

• the resulting SVM Classification (page 43) model is displayed in Figure 4.10 (right panel).

– the spectral region of interest was cropped to the fingerprint region between 800 cm-1

and 2000 cm-1.

INFO-CIRCLE Note

Cropping was primarily done to remove the highly absorbing C-H stretch region
around2900 cm-1, where very little light reaches the detector. This results in very high
and fluctuating absorbance, which is detrimental to proper data scaling (page 36). It
is important to note that the fingerprint region contains the relevant information for
differentiating the plastic samples. In contrast, the high-energy C-H stretch region
is common to all organic polymers and hence of little use for classification.

– the data was scaled using SNV scaling (page 36) - the data shown in Figure 4.10 reflects
this

– the confusion matrix (page 43) in Figure 4.10 indicates that a classifier that can distin-
guish the three different types of plastic has been trained successfully.
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(a) MIR Setup (b) Training Data & Model

Fig. 4.10: Plastic Classification by Mid-IR Spectroscopy

Figure 4.11 displays snapshots of real-time plastic identification using the Monitoring (page 44)
view of TII Spectrometry. Here, plastic samples were inserted into the mid-IR light beam while
continuously acquiring spectra. The samples were different from the training samples but of
known composition in order to verify classifier accuracy.

• accuracy was generally excellent provided sufficient light could pass through the sample -
the transmission setup will fail for thick samples

• SNV scaling (page 36) does a good job of standardizing the overall intensity and removing
baseline curvature. Hence, the SVM model is forced to focus exclusively on the shape and
position of the characteristic peaks—the true chemical information. This results in a model
that can - within reason - classify samples of different thickness (and hence difference ab-
sorbance) using transmission mid-IR spectroscopy.

• spectral differences between the three types of plastic are very obvious in the mid-IR - it is
hence no surprise that the classifier performs well

• no blank spectra were included during training. This is the reason for the misclassification
of the blank spectrum in Figure 4.11 as PE

• the model could easily be extended to incorporate more sample classes
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Fig. 4.11: Snapshots of real-time plastic classification using MIR spectroscopy

4.4.2 Near-Infrared Spectroscopy

Near-Infrared (NIR) spectroscopy between 800 nm to 2500 nm (12500 cm-1 to 4000 cm-1) is widely
used for rapid, non-destructive, and high-throughput plastic identification, particularly in recy-
cling and sorting facilities. Unlike Mid-IR, which excites the fundamental vibrations of bonds, NIR
light excites overtones (multiples of the fundamental frequency) and combination bands (sums
or differences of two or more fundamental frequencies). For plastic samples, the overtone of the
C-H stretching region is the dominant signal (Figure 4.12). The resulting NIR spectra are often
broad and heavily overlapping, making direct visual interpretation difficult. This makes near-IR
spectroscopy an ideal showcase for machine-learning based polymer identification.
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Fig. 4.12: Comparison of near-IR (blue and red) and mid-IR (pink and orange) spectra of plastic
samples. The near-IR spectra have been scaled by a factor of 1/2 along the x-axis.

The measurement setup is shown in Figure 4.13 (left). Analogous to the mid-IR experiment
(page 54), absorbance spectra were collected in transmission geometry and the transmitted
near-IR light was introduced into the spectrometer using a fiber. The exposure time was around 1
ms, sufficient for high-quality spectra due to the high absorbance of C-H bonds even at the second
harmonic (first overtone). For training the SVM classifier (Figure 4.13 right),

• spectra were cropped between 1000 nm and 2000 nm

• SNV scaling (page 36) was applied

• a blank spectrum (no sample in the beam path) was included in the training set, which con-
sists of only four spectra (PS, PP, PE, blank) in total.

INFO-CIRCLE Note

This is a (deliberately) minimal training set to demontrate the robustness and performance of
the SVM classifier. For a real-world model, more spectra would be included.

(a) NIR Setup (b) Training Data & Model

Fig. 4.13: Plastic Classification by Near-IR Spectroscopy

Figure 4.14 displays snapshots of real-time classification of different plastic samples using the
trained model. While performance is excellent,

• some samples (especially PS) suffer from high nonspecific absorbance / scattering in
the�near-IR range, resulting in a strong non-linear baseline. This baseline can mislead the
classifier and interfere with scaling.
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• the transmission geometry is very limiting since thicker or colored samples will not transmit
enough near-IR light for successful classification

Fig. 4.14: Snapshots of real-time plastic classification using near-IR spectroscopy

Using the baseline subtraction (page 35) preprocessing step can remove the non-linear baseline -
the result is displayed in Figure 4.15. This accentuates the absorption peaks and enables classifi-
cation even in the presence of non-specific absorbance or strong scattering.

(a) Raw Data (b) After Baseline Subtraction

Fig. 4.15: NIR Classification - Baseline Subtraction

To benchmark the classifier under more realistic conditions,
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• the classifier was trained using spectra collected in transmission after baseline subtraction
(the same four spectra used in Figure 4.13)

• the classifier was evaluated using near-IR reflections from the plastic sample surface using a
VIS-NIR fiber probe (Figure 4.16 left).

The result is displayed in Figure 4.16 (right)1. Baseline subtraction permits the SVM classifier to
solely focus on the chemical information contained in the absorption peaks, resulting in a model
with general applicability for plastic identification, independent of the collection geometry. De-
spite being trained on only four spectra, overfitting was avoided, as demonstrated by validating
the classifier using spectra that were not only obtained from samples different from the training
set but also recorded under drastically different experimental conditions.

(a) Setup (b) Result

Fig. 4.16: NIR Classification (Reflection Geometry)

1 The spectrum labelled pe 1ms was recorded in the transmission geometry.
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FIVE

APPENDICES

5.1 Fast Fourier Transform (FFT) Applied to FTIR Data

This section explains - mostly for educational purposes - how to extract spectra from space or
time-domain interferogram data from a Fourier Transform Infrared spectrometer.

Figure 5.1 (left) displays a double-sided interferogram. The x-axis displays the optical path differ-
ence (OPD) - the travel distance of the interferometer’s mirrors inmeters. The right panel displays
the shows burst around the region of zero OPD, where maximum interference is produced by the
instrument.

INFO-CIRCLE Note

This is the data as delivered by an ARCoptix (page 13) FTIR instrument.

Fig. 5.1: Interferogram (left) and zoom into the ZOPD region (right)

Extracting spectral information from this data involves the following steps:

1. (optional) padding the interferogram. Padding in the space domain is equivalent to interpo-
lation in the wavenumber domain and can be done to increase the spectral resolution.

2. preparing phase-correction data

3. extracting the sample spectrum from the phase-corrected interferogram

4. (optional) calculating absorption or transmission spectra using reference spectra
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The spectrum, 𝐵(𝜈), is obtained by taking the complex Fourier Transform of the interferogram,
𝐼(Δ):

𝐵(𝜈) =

∫︁ +∞

−∞
𝐼(Δ)𝑒−𝑖2𝜋𝜈Δ𝑑Δ

Where:

• 𝐼(Δ) is the interferogram as a function of optical path difference (Δ).

• 𝜈 is the wavenumber.

5.1.1 Phase Correction

In an ideal Fourier Transform (FT) system, the interferogram (the raw signal collected by the detec-
tor) should be perfectly symmetric around the Zero Path Difference (ZOPD) point, which is where
the twooptical paths in the interferometer are exactly equal. However, real-world FTIR instruments
introduce phase errors (𝜃(𝜈)) due to several factors, primarily:

• Instrumental imperfections: The optical components (like the beamsplitter material) have
wavelength-dependent refractive indices (dispersion), which means different wavelengths
travel through the material at slightly different speeds.

• Sampling/Electronics: Minor offsets between the ZPD and the first data point recorded, or
electronic filtering effects.

The phase correctionmethod used here is theMertz39 method, amultiplicative correctionmethod
that works in the frequency (wavenumber) domain. It estimates the phase error and then removes
it from the full measured spectrum.

Fig. 5.2: Phase Correction

The method relies on the assumption that the instrumental phase 𝜃(𝜈) is a slowly varying func-
tion of the wavenumber. This allows the phase to be accurately determined from a small, highly
symmetric region of the interferogram around the center burst (ZOPD) where the signal-to-noise
ratio is highest (gray shaded region in Figure 5.1).

39 https://opg.optica.org/ao/abstract.cfm?uri=ao-2-12-1332#Abstract
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• extract a small region centered on the ZOPD (Figure 5.2) 𝐼𝑠ℎ𝑜𝑟𝑡(Δ)

• apodize this region to avoid edge effects. Here, this is done using a triangular function to
yield 𝐼 ′𝑠ℎ𝑜𝑟𝑡(Δ)

• rotate the data to shift ZOPD data to 0

• perform the Fourier transform (FFT)

• The resulting complex spectrum is used to calculate the phase spectrum, 𝜃(𝜈), using the
relationship between the real and imaginary parts:

𝜃(𝜈) = arctan

(︂
ℑ(𝑧)
ℜ(𝑧)

)︂
where 𝑧 is the complex Fourier transform of 𝐼 ′𝑠ℎ𝑜𝑟𝑡(Δ)

5.1.2 Extracting the Sample Spectrum

Fig. 5.3: Extracting the Spectrum

Once we have obtained the phase 𝜃(𝜈), we can phase correct the full spectrum. To this end:

• the phase spectrum 𝜃(𝜈) is interpolated to the full resolution of the final desired spectrum.

• the full interferogram is rotated to shift the ZOPD data to bin 0

• the FFT is applied to the rotated data

• the final phase correction is applied bymultiplying the complex Fourier Transform of the full,
single-sided interferogram by a correction term:

𝐵𝑐𝑜𝑟𝑟𝑒𝑐𝑡𝑒𝑑(𝜈) = 𝐵𝑓𝑢𝑙𝑙(𝜈) · 𝑒−𝑖𝜃(𝜈)

• the spectrum is the real component ℜ(𝐵𝑐𝑜𝑟𝑟𝑒𝑐𝑡𝑒𝑑(𝜈))

Figure 5.3 panel 4 compares the spectrum extracted by this method (blue) and the spectrum ob-
tained by the spectrometer (orange). While the overall shape is similar, the intensity is different.
This is due to the fact that the spectrometer uses zero-padding by a factor of two to improve the
spectral resolution. Since the FFT is scaled by 1/n, this will affect the amplitude as well.
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5.1.3 Results

Fig. 5.4: Sample Interferograms

Figure 5.5 compares spectra that were manually extracted from interferograms (Figure 5.4) with
the spectrometer’s data processing. Three spectra are shown:

• a dark spectrum where no light hits the detector

• a reference spectrum of air

• a sample spectrum of a fairly thick polystyrene sample

Fig. 5.5: Interferogram Analysis

For analysis:

• data was zero-padded by a factor of 2

• phase correction data prepared as laid out in Section 5.1.1
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• the full interferogram was Fourier-transformed, phase corrected, and the spectrum com-
puted from the real component.

Overall, the agreement between manual processing and the spectrometer’s result is very good.
The residuals (differences between the spectra obtained by the twomethods, top rowof Figure 5.5)
are typically very small - only a few percent of the total signal strength. Larger differences occur
in regions where count rates are very low, for example in the dark spectrum at wavenumbers >
3000 cm-1 or for the polystyrene sample between 2800 and 3200 cm-1.

Fig. 5.6: Absorbance Spectra

Figure 5.6 shows an absorbance spectrum A(𝜈) calculated from the raw data

𝐴(𝜈) = − log10
𝐼𝑆(𝜈)− 𝐼𝐵(𝜈)

𝐼𝑅(𝜈)− 𝐼𝐵(𝜈)

where:

• IS(𝜈) is the sample spectrum

• IR(𝜈) is the reference spectrum

• IB(𝜈) is the background (dark count) spectrum

Again, agreement is very good except for regions of high absorbance. In these regions, even
small numerical differences will be emphasized due to division and application of the logarithm.
The right panels of Figure 5.6 show a comparison of key spectral regions - generally, agreement
is excellent.

5.1.4 An Annotated Example

This section contains Python sample code to perform interferogram analysis. It assumes that
numpy40 is available.

Loading CSV Data

This snippet loads .csv data into the opd and y numpy arrays.

1 data_sp = np.loadtxt(”data.csv”, skiprows=1, delimiter=',')
2 opd, y = data_sp[:, 0], data_sp[:, 1]

40 https://numpy.org/
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Padding

Here, we (optionally) pad the data by fillFactor. This is equivalent to increasing the scan range,
hence the opd array now is a array of twice the number of points with twice the range. The y
intensity data is padded symmetrically by appending zeros to the start and end.

1 opd = opd * fillFactor
2 opd = np.linspace(opd.min(), opd.max(), len(opd) * fillFactor)
3 y = np.pad(y, pad_width=(int((fillFactor - 1) / 2 * len(y)),), mode=

→˓'constant')

Phase Extraction

First, we obtain the index of the ZOPD.

Next,

• we use a 512 point window to extract a small region around the ZOPD yShort

• we use triangular apodization (page 67) to prepare y_apo

• we rotate the ZOPD bin to 0 using np.roll

• we compute the FFT using np.fft and compute the phase theta using the atan2 function

1 max_Y = np.argmin(np.abs(opd))
2

3 winSize = 512
4 xShort = np.arange(0, winSize)
5 yShort = y[max_Y - winSize//2 :max_Y + winSize//2]
6

7 apo_short = triangularApodization(yShort)
8 y_apo = yShort * apo_short
9 y_short_apo_rot = np.roll(y_apo[::1], winSize//2)
10 fft_short = np.fft.fft(y_short_apo_rot, norm='forward')
11 theta = np.atan2(fft_short.imag, fft_short.real)

Calculating the Spectrum

First, we interpolate the phase information to the full length of the (padded) spectrum.

1 theta_full = np.interp(np.linspace(xShort[0], xShort[-1], len(opd)),�
→˓xShort, theta)

Next, we calculate the spectrum:

• use np.roll to rotate

• perform the FFT

• apply the phase correction by multiplying the real part of the FFT by exp(−𝑖𝜃(𝜈))

• calculating the spectrum yy as the real part of the phase corrected component.

• truncate this to the length of half of the OPD since (after phase correction) the spectrum is
now symmetric

1 #alternatively, apply apodization here, eg
2 #y_apo = y * triangularApodization(y)
3 y_apo = y
4 y_full_apo_rot = np.roll(y_apo[::1], -max_Y)
5 fft_full = np.fft.fft(y_full_apo_rot, norm='forward')
6

7 yy = (fft_full * np.exp(-complex(0,1)*theta_full)).real[0:len(xx)]
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Calculating the Wavenumber Axis

Finally, we need to calculate the wavenumber axis. First, we calculate the wavenumber increment
dx in cm-1 and fill a numpy array xx using dx as the step size.

1 dx = 1/(opd.max() + np.abs(opd.min())) / 100
2 xx = np.linspace(0, len(opd)//2 * dx, len(opd)//2)

Apodization

A triangular apodization function for data y can be calculated using the following function

1 def triangularApodization(y:np.ndarray):
2 max_Y = np.argmax(y)
3 x = np.arange(0, len(y))
4 apo = 1-np.abs(x - max_Y) / (1 * len(x[max_Y:]))
5 apo[apo < 0] = 0
6 return apo

Alternatively,

• the Norton-Beer41 package contains a number of functions commonly used in FTIR analysis

• standard windowing functions (Hanning etc.) will work as well.

41 https://github.com/konstntokas/norton_beer
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SIX

WHAT’S NEW

6.1 TII Spectrometry 1.0.0 (Bittersuite)

This is the initial public release of TII Spectrometry.

69



Tokyo Instruments
6-18-14, Nishikasai, Edogawa-ku

Tokyo 134-0088
Japan

https://www.tokyoinst.co.jp/

https://www.tokyoinst.co.jp/

	Installation
	Supported Devices & Environments

	Recording Spectra
	General Use
	Connection
	Device Configuration
	Spectral Acquisition
	Display
	Device Configuration Files

	Recording Spectra
	Saving Spectra
	Background & Reference Spectra

	Spectrum Display
	Intensity Calibration
	File Input & Output

	Supported Devices
	Avenir Photonics
	ARCoptix
	Remote Connections

	StellarNet
	NLIR Spectrum
	NLIR Midwave

	Using Multiple Spectrometers
	Device Manager
	Use & Display Options

	Time-Lapse Recordings
	Time-Lapse
	Burst Recordings


	Analysis
	Time-Lapse Analysis
	The Time-Lapse Analysis Window

	Colorimetry
	Radiometry
	The Settings Bar
	The IES TM-30-18 Color Vector Graphic
	The Result Sidebar
	Color Quality Metrics
	The Test Color Sample Graph


	Modeling
	General Overview
	Pre-Processing
	Scaling Methods
	Min-Max Scaling
	Standard Normal Variate Scaling


	Regression Analysis
	Training
	Linear Regression
	Support Vector Regression

	Prediction

	Classification Analysis
	Training
	Prediction

	Monitoring


	Application Examples
	The Solar Spectrum
	Colorimetry of Light Sources & Color Charts
	Colorimetric Analysis of the Spectrum of the Sun
	Reflective Colorimetric Analysis

	Radiometric Analyis of Light Sources
	Results - Color Quality
	Color Temperature & Planckian Loci

	Plastic Identification
	Mid-Infrared Spectroscopy
	Near-Infrared Spectroscopy


	Appendices
	Fast Fourier Transform (FFT) Applied to FTIR Data
	Phase Correction
	Extracting the Sample Spectrum
	Results
	An Annotated Example
	Loading CSV Data
	Padding
	Phase Extraction
	Calculating the Spectrum
	Calculating the Wavenumber Axis
	Apodization



	What’s New
	TII Spectrometry 1.0.0 (Bittersuite)


